How to setup SignalWire and Twilio in Wazo. First, I should state that SignalWire is a competitor to Twilio. It is brought to us by the founders of Freeswitch.

I’ve been playing around with them for just a short time and have liked what they have done so far. I had problems for forever getting Twilio to work with outgoing calls in Wazo. Now, I can finally say that I have it working 100%. Same goes for SignalWire.

When you are filling out the SIP trunk section here is the information you will need:

  • Authentication username: this is something you picked in signalwire.
  • password: you picked this right after the username.
  • connection type: honestly – I think friend and peer works. I don’t think it is used.
  • IP Addressing: Static and then the server name is the name of your end point. This should be your project name followed by some code and then ends with sip.signalwire.com. you need to enter it all.
  • Skip the rest of that
  • Skip register
  • Go to Advanced tab – this was the key for me.
  • Rewriting the From field-Domain: user your username here
  • Rewriting the From field-Domain: here you put your SIP Endpoint
  • amaflag: default
  • I also filled in insecure (ALL) and port (5060) but again I am not entirely sure they are used.

That’s it. Twilio is the same way but usually the terminology is just a bit different.

Also want to mention that when setting up a phone they recommend TLS and port 5061. However, I think if you are using Asterisk you still need to use UDP and 5060.